Derik Whittaker

Syndication

News


Images in this post missing? We recently lost them in a site migration. We're working to restore these as you read this. Should you need an image in an emergency, please contact us at imagehelp@codebetter.com
NHibernate Newbie Needs Help

See my comments below.... Figured out what stupid thing i was doing... :( 

 

All, I am trying out NHibernate for the first time and I am having some troubles getting it up and running.  I have downloaded the sample app from Hibernate.org and started to look at it as well as other samples from the net.

When I try to config NHibernate in my own application I get an error while trying to load an Assembly with the * .hbm.xml files.  Yes I do have that file marked as an embedded resource.

The error I am getting is the following:

System.IO.FileNotFoundException: Could not load file or assembly 'Iesi.Collections, Version=1.0.0.3, Culture=neutral, PublicKeyToken=aa95f207798dfdb4' or one of its dependencies. The system cannot find the file specified.


at NHibernate.Cfg.AssemblyHbmOrderer.GetHbmFiles()
at NHibernate.Cfg.Configuration.AddResources(Assembly assembly, IList resources, Boolean skipOrdering)
at NHibernate.Cfg.Configuration.AddAssembly(Assembly assembly, Boolean skipOrdering)
at NHibernate.Cfg.Configuration.AddAssembly(Assembly assembly)
at NHibernate.Cfg.Configuration.AddAssembly(String assemblyName)

 

I am using version 1.2.0.4000 of NHibernate and have the following assembles in my output folder.

Castle.DynamicProxy.dll

1.1.5.0

Iesi.Collections.dll

1.0.0.3

log4net.dll

1.2.10.0

NHibernate.dll

1.2.0.4000

Nullables.dll

1.2.0.4000

 
Now according the example’s readme I need the HashCodeProvider.dll and iTextSharp.dll assemblies, is this true?  What versions?  Where can I find them?

Here is the code causing the issues.


Can anyone help me with this?


Posted 06-04-2007 7:21 AM by Derik Whittaker
Filed under: ,

[Advertisement]

Comments

badgrs wrote re: NHibernate Newbie Needs Help
on 06-04-2007 10:48 AM

The only difference between that and my /Bin folder is I also have Nullable.NHibernate.dll No idea if that matters or not, sorry I can't be more help I'm only starting out myself!

Derik Whittaker wrote re: NHibernate Newbie Needs Help
on 06-04-2007 10:56 AM

Badgrs,

I added that assembly and nothing.  Still fails.  

Next idea?  Help

Derik Whittaker wrote re: NHibernate Newbie Needs Help
on 06-04-2007 8:18 PM

Ok,

I feel like a dumb ass.  I have all my projects outputting to a single directory.  The one with all the NHibernate assembly's.  Turns out that the test project was NOT outputting to that directory....thus explaining the File Not Found exception.....

I will the dumb ass of the day award...

PartialClass wrote re: NHibernate Newbie Needs Help
on 06-05-2007 2:28 PM

it happens some times. Specially, when u r working on some thing new and complex

hector wrote re: NHibernate Newbie Needs Help
on 09-17-2008 10:05 AM

how you can add a new assembly?

i was trying to implement role provider, but don't work

About The CodeBetter.Com Blog Network
CodeBetter.Com FAQ

Our Mission

Advertisers should contact Brendan

Subscribe
Google Reader or Homepage

del.icio.us CodeBetter.com Latest Items
Add to My Yahoo!
Subscribe with Bloglines
Subscribe in NewsGator Online
Subscribe with myFeedster
Add to My AOL
Furl CodeBetter.com Latest Items
Subscribe in Rojo

Member Projects
DimeCasts.Net - Derik Whittaker

Friends of Devlicio.us
Red-Gate Tools For SQL and .NET

NDepend

SlickEdit
 
SmartInspect .NET Logging
NGEDIT: ViEmu and Codekana
LiteAccounting.Com
DevExpress
Fixx
NHibernate Profiler
Unfuddle
Balsamiq Mockups
Scrumy
JetBrains - ReSharper
Umbraco
NServiceBus
RavenDb
Web Sequence Diagrams
Ducksboard<-- NEW Friend!

 



Site Copyright © 2007 CodeBetter.Com
Content Copyright Individual Bloggers

 

Community Server (Commercial Edition)