All Tags » HowTo » Agile (RSS)

Browse Site by Tags

Showing related tags and posts across the entire site.
  • AppHarbor - Azure Done Right AKA Heroku for .NET

    Easy and Instant deployments and instant scale for .NET? Awhile back a few of us were looking at Ruby Gems as the answer to package management for .NET . The gems platform supported the concept of DLLs as packages although some changes would have needed to happen to have long term use for the entire...
    Posted to Rob Reynolds - The Fervent Coder by Rob Reynolds on 02-16-2011
    Filed under: NHibernate, Fluent NHibernate, RoundhousE, HowTo, UppercuT, Development, Git, Tools, .NET, Agile, Gems, Challenge
  • Testing that EventHandlers were wired up correctly with NUnit and Rhino Mocks

    Today I was trying to wrap some code in some tests (I got lazy and did not create the tests first… shot me).  What I was trying to ensure was that my event handlers I passed into a method were actually being wired up for usage.  Now I searched around the net for a while to see if there was...
    Posted to Derik Whittaker by Derik Whittaker on 08-24-2010
    Filed under: Agile, .Net, TDD, Rhino Mocks, HowTo
  • Teaching someone to test using an Isolation Framework

    Part of my job at work is to teach and mentor other developers on our team. Right now I am in the process of teaching two of our developers how to create unit tests (notice I did NOT say integration tests because most anyone can do those). We are also learning how to create our tests by utilizing an...
    Posted to Derik Whittaker by Derik Whittaker on 12-30-2008
    Filed under: Agile, TDD, Rhino Mocks, Opinion, HowTo
  • Nasty MSBuild Error - MSB4126 "Debug|HPD" issue

    Today I was trying to put together a simple NAnt build script for a 'play' project of mine. This build script is real simple, it only calls MSBuild right now. However, when I was running the script I kept getting the message 'error MSB4126: The specified solution configuration "Debug...
    Posted to Derik Whittaker by Derik Whittaker on 02-29-2008
    Filed under: Development Tools, Agile, HowTo
  • StructureMap 101 Error Gotcha

    Today I was putting together a test app for a few presentations I am doing in the coming weeks (announcements on these coming soon).  While doing this I kept getting a 101 exception when trying to build an object via StructureMap's ObjectFactory (error information here ). Error message Assembly...
    Posted to Derik Whittaker by Derik Whittaker on 02-02-2008
    Filed under: Development Tools, Agile, StructureMap, HowTo
Page 1 of 2 (40 items) 1 2 Next >

About The CodeBetter.Com Blog Network
CodeBetter.Com FAQ

Our Mission

Advertisers should contact Brendan

Subscribe
Google Reader or Homepage

del.icio.us CodeBetter.com Latest Items
Add to My Yahoo!
Subscribe with Bloglines
Subscribe in NewsGator Online
Subscribe with myFeedster
Add to My AOL
Furl CodeBetter.com Latest Items
Subscribe in Rojo

Member Projects
DimeCasts.Net - Derik Whittaker

Friends of Devlicio.us
Red-Gate Tools For SQL and .NET

NDepend

SlickEdit
 
SmartInspect .NET Logging
NGEDIT: ViEmu and Codekana
LiteAccounting.Com
DevExpress
Fixx
NHibernate Profiler
Unfuddle
Balsamiq Mockups
Scrumy
JetBrains - ReSharper
Umbraco
NServiceBus
RavenDb
Web Sequence Diagrams
Ducksboard<-- NEW Friend!

 



Site Copyright © 2007 CodeBetter.Com
Content Copyright Individual Bloggers

 

Community Server (Commercial Edition)